Error 404 при открытии страницы мода

  • 3 Ответов
  • 454 Просмотров

danilasar

  • Сообщений: 3
    • Просмотр профиля
Доброго времени суток. Недавно поставил Danneo CMS 1.5.0 на локальную машину (Linux Ubuntu, Apache 2, PHP7, MariaDB). Установка прошла без проблем. /setup удалил, на /core/config.php поставил права 444.
Добавил мод "статьи". Обратился к нему через /article, сервер вернул ошибку 404. По всем остальным страницам мода тоже самое (/article/rss, /article/rss-yandex и т.д.). Попробовал поставить "Статьи" как основной на главную, на / сервер ответил без ошибок. Если коротко, то:
/article          - Error 404
/article/         - Error 404
/                    - Работает
/?dn=articles - Работает
С чем это может быть связано и куда смотреть?
« Последнее редактирование: 26 Марта 2018, 16:42:10 от danilasar »

sovyonok

  • Сообщений: 48
    • Просмотр профиля
    • Прогулки по Москве
Re: Error 404 при открытии страницы мода
« Ответ #1 : 26 Марта 2018, 13:40:14 »
Связано с архитектурой системы.
Смотреть в поиск.
Тут обсуждалось http://forum.danneo.ru/index.php?topic=80.0

danilasar

  • Сообщений: 3
    • Просмотр профиля
Re: Error 404 при открытии страницы мода
« Ответ #2 : 26 Марта 2018, 13:48:41 »
Связано с архитектурой системы.
Смотреть в поиск.
Тут обсуждалось http://forum.danneo.ru/index.php?topic=80.0
Что /article/, что /article - всё одно. На /index.php?dn=article всё работает. В любом случае, спасибо за наводку. Буду копать дальше.
« Последнее редактирование: 26 Марта 2018, 15:58:50 от danilasar »

danilasar

  • Сообщений: 3
    • Просмотр профиля
Re: Error 404 при открытии страницы мода
« Ответ #3 : 26 Марта 2018, 18:17:35 »
Сейчас загрузился с винды (Win7 + OpenServer), всё работает.
« Последнее редактирование: 26 Марта 2018, 21:23:23 от danilasar »