Danneo CMS v1.5.0 (alpha) v3

  • 30 Ответов
  • 6683 Просмотров

Neon

  • Сообщений: 670
    • Просмотр профиля
    • Danneo CMS
Danneo CMS v1.5.0 (alpha) v3
« : 07 Июня 2016, 04:38:11 »
Выложил на tools:
http://tools.danneo.ru/down/open/danneo-cms-v1-5-0-alpha-v3.html

Добавлен модуль «Каталог файлов».
Добавлены все патчи, а также, учтены последние предложения.
Добавлен вывод авторов в анонсах и на полных страницах, в модулях (новости, статьи, файлы, фотогалерея).
Добавлена возможность отправки сообщения о новом добавлении на сайте, во всех этих модулях.

Остался один модуль, Каталог товаров (магазин).
Модуль сложный, на адаптацию и доработку может уйти 1-2 недели.
DANNEO ™

jek

  • Сообщений: 57
    • Просмотр профиля
Re: Danneo CMS v1.5.0 (alpha) v3
« Ответ #1 : 07 Июня 2016, 09:21:04 »
Спасибо. Будем тестировать.

Vinigret76

  • Сообщений: 15
    • Просмотр профиля
Re: Danneo CMS v1.5.0 (alpha) v3
« Ответ #2 : 07 Июня 2016, 14:03:06 »
У мода media в сборке не тот index.php - от мода contact

Neon

  • Сообщений: 670
    • Просмотр профиля
    • Danneo CMS
Re: Danneo CMS v1.5.0 (alpha) v3
« Ответ #3 : 07 Июня 2016, 15:06:07 »
Барабашка помогал собирать сборку ) Другого объяснения не могу найти.

Патч в архиве, сборку обновил.
DANNEO ™

Neon

  • Сообщений: 670
    • Просмотр профиля
    • Danneo CMS
Re: Danneo CMS v1.5.0 (alpha) v3
« Ответ #4 : 07 Июня 2016, 15:44:14 »
Исправлена ошибка прикрепления презентации в каталоге файлов.
Патч в архиве, сборка обновлена.
DANNEO ™

студент

  • Сообщений: 107
    • Просмотр профиля
    • Мировые новости
Re: Danneo CMS v1.5.0 (alpha) v3
« Ответ #5 : 08 Июня 2016, 09:23:47 »
На главной в блоках Новости, Статьи, Файлы ... выводится {author}
--------------------
На главной в блоке Файлы если навести мышь на метки, то всплывает {tag_desc}
тоже самое в открытой статье.
--------------------
Пользователь добавил файл на сайт. Админка -- открыл добавленный файл для редактирования, а там:
Notice: Undefined index: subtitle in /public_html/test/admin/mod/down/index.php on line 1998
и поле "ЧПУ замена" пустое.
(патч "прикрепления презентации в каталоге файлов" устанавливал)
--------------------
После добавлении статьи пользователем над шапкой сайта выскочила
Notice: [8] Undefined variable: text /public_html/test/mod/article/add.php on line 387
--------------------
После добавлении новости пользователем над шапкой сайта выскочила
Notice: [8] Undefined variable: text /public_html/test/mod/news/add.php on line 387
--------------------
при добавлении новостии статьи пользователем кнопка Добавить не срабатывает с первого раза. В Фотогалерея и Каталог файлов все нормально.
« Последнее редактирование: 08 Июня 2016, 10:18:05 от студент »

Neon

  • Сообщений: 670
    • Просмотр профиля
    • Danneo CMS
Re: Danneo CMS v1.5.0 (alpha) v3
« Ответ #6 : 08 Июня 2016, 18:40:03 »
Чем дальше в лес, тем больше дров )
Спасибо, сегодня пройдусь.
DANNEO ™

Neon

  • Сообщений: 670
    • Просмотр профиля
    • Danneo CMS
Re: Danneo CMS v1.5.0 (alpha) v3
« Ответ #7 : 08 Июня 2016, 21:12:32 »
Исправления по последним ошибкам.
Патч в архиве, сборку обновил.

Цитировать
при добавлении новостии статьи пользователем кнопка Добавить не срабатывает с первого раза. В Фотогалерея и Каталог файлов все нормально.
Не выявил проблемы, возможно свойства браузера.
DANNEO ™

buzzerm

  • Сообщений: 9
    • Просмотр профиля
Re: Danneo CMS v1.5.0 (alpha) v3
« Ответ #8 : 13 Июня 2016, 18:34:53 »
При клонировании модов, запись в таблицу идет только tables. При добавлении вручную setting, все работает. Удаляется все нормально.
Не могу понять, с какими модами происходит самопроизвольное удаление таблиц subscribe и poll.
MySQL Server5.6.2 PHP5.4.45
down
Ошибка /block/b-User.php on line 151

Neon

  • Сообщений: 670
    • Просмотр профиля
    • Danneo CMS
Re: Danneo CMS v1.5.0 (alpha) v3
« Ответ #9 : 13 Июня 2016, 20:53:25 »
Цитировать
При клонировании модов, запись в таблицу идет только tables. При добавлении вручную setting, все работает. Удаляется все нормально.
Не может быть, в каком моде?
Настройки для клонов добавляются нормально.
Ланги могут не добавляться, ну это и понятно, при импорте языковых лангов дубли игнорируются.

Цитировать
Не могу понять, с какими модами происходит самопроизвольное удаление таблиц subscribe и poll.
Опишите более подробно, что делали.

Цитировать
Ошибка /block/b-User.php on line 151
Пример ошибки.
DANNEO ™

buzzerm

  • Сообщений: 9
    • Просмотр профиля
Re: Danneo CMS v1.5.0 (alpha) v3
« Ответ #10 : 13 Июня 2016, 23:18:01 »
Зарегил пользователя, создал блок пользователя, появилась ошибка 151, добавить файл не выводится, удаляешь в b-User добавление, ошибка тухнет. В настройках мода, добавление разрешено. Ошибка светиться даже на фоне файл браузера. 
« Последнее редактирование: 13 Июня 2016, 23:27:37 от buzzerm »

buzzerm

  • Сообщений: 9
    • Просмотр профиля
Re: Danneo CMS v1.5.0 (alpha) v3
« Ответ #11 : 13 Июня 2016, 23:29:26 »
Клонировал моды photos и article, контент тоже не добавляется. Тестирую на хосте, два варианта при разных настройках.
« Последнее редактирование: 13 Июня 2016, 23:32:26 от buzzerm »

buzzerm

  • Сообщений: 9
    • Просмотр профиля
Re: Danneo CMS v1.5.0 (alpha) v3
« Ответ #12 : 13 Июня 2016, 23:39:40 »
Subscribe и poll возможно удалялись при установке и удалении клонов. Я так понимаю, переустановка мода пользователь, получается обязательна.

Neon

  • Сообщений: 670
    • Просмотр профиля
    • Danneo CMS
Re: Danneo CMS v1.5.0 (alpha) v3
« Ответ #13 : 14 Июня 2016, 10:09:37 »
Я так понимаю, вы сами не помните, что делали, и когда оно удалилось.
Зачем тогда пишите, что это ошибки.
buzzerm, если вы пришли сюда троллить, то разговор будет короткий.

Первое предупреждение.
DANNEO ™

buzzerm

  • Сообщений: 9
    • Просмотр профиля
Re: Danneo CMS v1.5.0 (alpha) v3
« Ответ #14 : 14 Июня 2016, 19:53:27 »
Пора банить! Это третье, если не четвертое с 0.3 версии. И заметь, всe предупреждения на тестировании. Ты так никогда, форум не вернеш. Смотри, пять десять гостей, и один два залогиненых.
Другие системы как тестируют? Два три схожих предупреждающих поста, значит сигнал, начинается движение. Если кнопка -добавить- в интерфейсе пользователя,  у двух тестеров, не срабатывает с первого клика, это и есть сигнал.